B2B Site Orders + Pricing Issue

Incident Report for Julius Silvert

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 17:12 EDT

Identified

We've identified an issue with the API that pulls pricing and orders from S2K which is affecting the B2B website. The issue is on S2K's end, and they have been contacted to investigate the issue.
Posted Apr 01, 2026 - 12:18 EDT
This incident affected: Websites (my.juliussilvert.com (B2B)).