B2B Site Orders + Pricing Issue

Incident Report for Julius Silvert

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 14:51 EDT

Identified

We've identified an issue with the API that pulls pricing and orders from S2K which is effecting the B2B website. Vendors have been contacting and are investigating the issue.
Posted Mar 30, 2026 - 13:14 EDT
This incident affected: Websites (my.juliussilvert.com (B2B)).